DragRaceResults.Com    Bracket Talk    Bracket Talk Forum  Hop To Forum Categories  Tech Talk - by Abruzzi    MSD 7765 Wide Band Sensor
Page 1 2 
Go
New
Find
Notify
Tools
Reply
  
MSD 7765 Wide Band Sensor
 Login/Join
 
DRR Sportsman
Picture of suprodn
posted
What O2 sensor comes in the kit is it a Bosch. I need a extension cable the cable from the module is too short to reach my left O2.
 
Posts: 63 | Location: Watchn my motor go boom on the dyno | Registered: April 04, 2009Reply With QuoteReport This Post
DRR Pro
posted Hide Post
quote:
Originally posted by markemark:
quote:
Originally posted by suprodn:
What O2 sensor comes in the kit is it a Bosch. I need a extension cable the cable from the module is too short to reach my left O2.


Another way to do this is to move the CAN-Bus base unit closer to the exhaust so that the O2 sensor reaches. Use these 2’ , 4’, 6’ CAN-Bus extensions MSD 7782, 7784, 7786
 
Posts: 2503 | Location: 53056 | Registered: December 30, 2009Reply With QuoteReport This Post
DRR Pro
posted Hide Post
It’s also possible (not exactly sure) that this cable can also be used between the 7765 and the 7740 CAN-Bus.
 
Posts: 2503 | Location: 53056 | Registered: December 30, 2009Reply With QuoteReport This Post
DRR Sportsman
Picture of suprodn
posted Hide Post
I’ve already mounted can-bus hub and both modules on my right door x.
 
Posts: 63 | Location: Watchn my motor go boom on the dyno | Registered: April 04, 2009Reply With QuoteReport This Post
DRR Sportsman
Picture of Stephen Hughes
posted Hide Post
I was wondering about this too since I just ordered one for my dragster. Ignition box way up front and obviously O2’s way out back...


The Pull-Out....for when you want to work smarter, not harder!!!
 
Posts: 336 | Location: Texas | Registered: September 12, 2005Reply With QuoteReport This Post
DRR Sportsman
Picture of suprodn
posted Hide Post
 
Posts: 63 | Location: Watchn my motor go boom on the dyno | Registered: April 04, 2009Reply With QuoteReport This Post
DRR Pro
Picture of Alaskaracer
posted Hide Post
How long are the leads for those? I’m pulling off my LM2 and going to the MSD ones. For my dragster.


Mark Goulette
Owner/Driver of the Livin' The Dream Racing dragster
www.livinthedreamracing.com
"Speed kills but it's better than going slow!"
Authorized Amsoil Retailer
 
Posts: 1503 | Location: Back home in Alaska! | Registered: February 13, 2011Reply With QuoteReport This Post



DRR Sportsman
Picture of sr4440
posted Hide Post
quote:
Originally posted by suprodn:
What O2 sensor comes in the kit is it a Bosch. I need a extension cable the cable from the module is too short to reach my left O2.


the O2 sensor that most use (lm1, lm2, Daytona) is the Bosch LSU 4.2 sensor, msd states that theirs is the LSU 4.9

if your going to add a extension I would use a 4.9 cable. their are measurements on this site to determine which sensor you have.
http://www.innovatemotorsports.com/support/49.php

Joe


Without data, you’re just another guy with an opinion.
 
Posts: 1301 | Location: TEXAS | Registered: February 07, 2003Reply With QuoteReport This Post
DRR Sportsman
Picture of suprodn
posted Hide Post
quote:
Originally posted by Coloradoracer:
How long are the leads for those? I’m pulling off my LM2 and going to the MSD ones. For my dragster.


They show 12” 24” and 36” in stock and will make custom lengths also
 
Posts: 63 | Location: Watchn my motor go boom on the dyno | Registered: April 04, 2009Reply With QuoteReport This Post
DRR Trophy
posted Hide Post
Daytona Sensors made me two custom length extensions for my Wego. If I remember correctly one was 91" and the other was 105. Both of them to the door cost me 35 bucks total. May be worth a phone call.
 
Posts: 97 | Location: Ohio | Registered: October 06, 2015Reply With QuoteReport This Post
DRR Pro
Picture of RacerVX54
posted Hide Post
Anyone have any issues? Installed mine on the grid and i am getting a red blinking light. Heater open fault as soon as it the pc starts up with the program.. Called wonderful MSD and got hey techs are in the other building we can call you back tomorrow... And i was speaking to a tech line guy!! SMH


"Just Shut Up and Race"

Brian Martin
Martin Racing
5.66 @121.55
 
Posts: 1405 | Location: Va.Beach .Va | Registered: August 03, 2005Reply With QuoteReport This Post
DRR Pro
posted Hide Post
quote:
Originally posted by RacerVX54:
Anyone have any issues? Installed mine on the grid and i am getting a red blinking light. Heater open fault as soon as it the pc starts up with the program.


Is the Red wire from the O2 Sensor Module connected to a “Continuous” +12v battery source?
 
Posts: 2503 | Location: 53056 | Registered: December 30, 2009Reply With QuoteReport This Post
DRR Pro
Picture of RacerVX54
posted Hide Post
quote:
Originally posted by markemark:
quote:
Originally posted by RacerVX54:
Anyone have any issues? Installed mine on the grid and i am getting a red blinking light. Heater open fault as soon as it the pc starts up with the program.


Is the Red wire from the O2 Sensor Module connected to a “Continuous” +12v battery source?


Not sure pops wired it up. I do know the o2
only comes on when the ignition switch it on


"Just Shut Up and Race"

Brian Martin
Martin Racing
5.66 @121.55
 
Posts: 1405 | Location: Va.Beach .Va | Registered: August 03, 2005Reply With QuoteReport This Post
DRR Pro
posted Hide Post
quote:
Originally posted by RacerVX54:
quote:
Originally posted by markemark:
quote:
Originally posted by RacerVX54:
Anyone have any issues? Installed mine on the grid and i am getting a red blinking light. Heater open fault as soon as it the pc starts up with the program.


Is the Red wire from the O2 Sensor Module connected to a “Continuous” +12v battery source?


Not sure pops wired it up. I do know the o2
only comes on when the ignition switch it on


Turning ignition switch ON to Grid turns the modules on attached to the CAN-bus hub for communication..

Select 7765 in Grid and go to the Gauge 1 tab. Select the Battery Voltage and Heater Voltage channels. What do they indicate?
 
Posts: 2503 | Location: 53056 | Registered: December 30, 2009Reply With QuoteReport This Post



DRR Pro
Picture of RacerVX54
posted Hide Post
Battery voltage is 12.6 off and car running was 13.8 I o2 read 6.4 and but it wouldn't change like it didn't read. As soon as you select the o2 setting the heater open fault would pop on. Clear it and come right back on.

This message has been edited. Last edited by: RacerVX54,


"Just Shut Up and Race"

Brian Martin
Martin Racing
5.66 @121.55
 
Posts: 1405 | Location: Va.Beach .Va | Registered: August 03, 2005Reply With QuoteReport This Post
DRR Pro
posted Hide Post
quote:
Originally posted by RacerVX54:
Battery voltage is 12.6 off and car running was 13.8 I o2 read 6.4 and but it wouldn't change like it didn't read. As soon as you select the o2 setting the heater open fault would pop on. Clear it and come right back on.


What does the “Heater Voltage “ channel display for voltage ?
 
Posts: 2503 | Location: 53056 | Registered: December 30, 2009Reply With QuoteReport This Post
DRR Pro
Picture of RacerVX54
posted Hide Post
Mark i am not sure i will check that in the morning.


"Just Shut Up and Race"

Brian Martin
Martin Racing
5.66 @121.55
 
Posts: 1405 | Location: Va.Beach .Va | Registered: August 03, 2005Reply With QuoteReport This Post
DRR Pro
posted Hide Post
quote:
Originally posted by RacerVX54:
Mark i am not sure i will check that in the morning.


Prior to starting, unplug the Oxygen Sensor from the O2 sensor Module and look at the pins (qty 6 ) in the plug ends to see if they all look the same for position. If good, then re-seat plugs and try viewing the Heater Voltage. No work, call MSD. They’ll ask you some of the same questions.
 
Posts: 2503 | Location: 53056 | Registered: December 30, 2009Reply With QuoteReport This Post
DRR Pro
Picture of RacerVX54
posted Hide Post
Thanks will do


"Just Shut Up and Race"

Brian Martin
Martin Racing
5.66 @121.55
 
Posts: 1405 | Location: Va.Beach .Va | Registered: August 03, 2005Reply With QuoteReport This Post
DRR Pro
Picture of RacerVX54
posted Hide Post
Heater voltage is 0.00


"Just Shut Up and Race"

Brian Martin
Martin Racing
5.66 @121.55
 
Posts: 1405 | Location: Va.Beach .Va | Registered: August 03, 2005Reply With QuoteReport This Post
  Powered by Social Strata Page 1 2  
 

DragRaceResults.Com    Bracket Talk    Bracket Talk Forum  Hop To Forum Categories  Tech Talk - by Abruzzi    MSD 7765 Wide Band Sensor

© DragRaceResults.com 2024