DragRaceResults.Com    Bracket Talk    Bracket Talk Forum  Hop To Forum Categories  Tech Talk - by Abruzzi    Dragster doesn’t run what it should
Page 1 2 3 
Go
New
Find
Notify
Tools
Reply
  
Dragster doesn’t run what it should
 Login/Join
 
DRR Top Comp
posted Hide Post
quote:
Originally posted by Lenny5160:
Using the 'K value' formula for torque converters, a difference of about 65 lb/ft will change the stall 300 RPM.


Yep that's it, assuming the cooler and lines flow, input shaft stator tube configuration is the same.

Plus or minus 100 rpm for differences.
 
Posts: 9398 | Location: Madeira Beach Fl. | Registered: June 12, 2018Reply With QuoteReport This Post
DRR Sportsman
posted Hide Post
Any idea what rear gear you have? What rear tires are on it? If it is slow to the 60’ this could be part of the problem

I did not see, but gas or alcohol? Are you running an in-line fuel filter? If you are running an in-line fuel filter just toss it
 
Posts: 808 | Location: Georgia | Registered: May 09, 2008Reply With QuoteReport This Post
DRR Trophy
posted Hide Post
The real question is why is this thing down almost 100 hp?
That’s why it won’t run what you think it should. Depending on where you’re running, if your at any altitude at all, not at acto, it’s running pretty close to what I would expect a 875 hp car to run at 1950 lbs. Especially if the car has big tires or a wing on it.
 
Posts: 106 | Location: Jackson, MS | Registered: July 31, 2001Reply With QuoteReport This Post
DRR Sportsman
posted Hide Post
Just throwing this pit there as we had a similar issue in our dragster. We had a red 7Al-3 box in the car. We had a timing retard chip that was pulling 22 degrees of timing once the brake was released. Was actually a 2 degree chip in it as we did not have a zero and juts forgot it was in there. So if you checked the timing even at a higher RPM it would read 33 degrees. Hit the brake and check it again and it was at 11 degrees. Car ran fine was just slow. Running 7.60's here in Vegas. Replaced it with a new 2 degree chip and car went 7.39 next pass. Just something to check. I was scratching my head trying to find the issue for a couple races, was just a fluke I put a timing light on it when he was warming it up on the stands and checked it after he had put it in reverse


"I am not ashamed to confess I am ignorant of what I do not know."
Marcus Tullius Cicero
 
Posts: 994 | Location: Las Vegas, NV | Registered: April 14, 2004Reply With QuoteReport This Post
DRR Sportsman
Picture of sr4440
posted Hide Post
can you post a picture of the plugs?


Joe


Without data, you’re just another guy with an opinion.
 
Posts: 1301 | Location: TEXAS | Registered: February 07, 2003Reply With QuoteReport This Post
DRR Sportsman
posted Hide Post
You've stated the wires are on correctly for a 5-7 swap. Have you verified the cam is a 5-7 swap cam?


I used to be a people person, but people ruined that.
 
Posts: 225 | Location: Usually home | Registered: January 27, 2013Reply With QuoteReport This Post
DRR Trophy
posted Hide Post
I had the sportman 540 from shaffiroff on gas max 38 timing ran best 7.90. Changed to alcohol and added vacumn pump ran 7.75 34 degrees timing. I freshened it and bored it .100 to make it 565 same everything from shaffiroff runs 7.62 . I agree with checking the stall on convertor picked up 200 rpm after making it a 565.
 
Posts: 36 | Location: canada | Registered: January 21, 2017Reply With QuoteReport This Post



DRR Trophy
posted Hide Post
FWIW I had a very similar issue when we built my hardtail didn't run anywhere near what most knowledgeable people thought it should. Went through all the stuff suggested here and continued pulling my hair out. Finally pulled the rear-end and took it to a very respected guy...turns out to be set up wrong! Had it set up correctly and car picked up 3 tenths in the eighth and was very consistent.


Jason Compton
 
Posts: 34 | Location: Tennessee | Registered: January 13, 2018Reply With QuoteReport This Post
DRR Sportsman
Picture of Bob Nichols
posted Hide Post
What intake is on this setup? And how big are the exhaust tubes? Had a 496 that was a turd until we changed the header size and intake. Still made the same HP, but accelerated drastically different after changes.
 
Posts: 157 | Location: Charlestown, IN U.S.A | Registered: October 30, 2000Reply With QuoteReport This Post
DRR Trophy
posted Hide Post
Am I the only one here that doesn't think 875HP equates to 7.70's at 170? I would expect 7.80's maybe but it would take at least 1000HP to go 7.50's at that weight of 1950. JMO.
 
Posts: 82 | Location: Salt Lake City | Registered: August 06, 2009Reply With QuoteReport This Post
DRR S/Pro
Picture of Lenny5160
posted Hide Post
quote:
Originally posted by bbtommyd:
Am I the only one here that doesn't think 875HP equates to 7.70's at 170? I would expect 7.80's maybe but it would take at least 1000HP to go 7.50's at that weight of 1950. JMO.


My car is about 80# lighter but it went 7.80s-90s with my 505 in it which was a little shy of 800 hp.

I'd expect the car in this thread to be going 70s-80s, and that's using my Midwest brain where actual altitude is around 1000' so it's on the slow side.


Tony Leonard
 
Posts: 3169 | Location: Inver Grove Heights, MN | Registered: March 18, 2004Reply With QuoteReport This Post
  Powered by Social Strata Page 1 2 3  
 

DragRaceResults.Com    Bracket Talk    Bracket Talk Forum  Hop To Forum Categories  Tech Talk - by Abruzzi    Dragster doesn’t run what it should

© DragRaceResults.com 2024