Share |
Go
New
Find
Notify
Tools
Reply
  
Msd 7720
 Login/Join
 
DRR Sportsman
Picture of Mike Frizie
posted
Anyone seen any issues out of these?


Michael Frizie
ET 2471
2011 Diamond Chassis Dragster
 
Posts: 535 | Location: Winston, GA | Registered: April 10, 2002Reply With QuoteReport This Post
DRR Pro
posted Hide Post
I’ve personally seen one MSD 7720 and heard of several that have failed. These can be repaired when sent back to MSD. My only 7720 over 10 yrs old has always worked. I believe the 7720 fails less than the 7730.

The temporary back-up to the 7720 that I carry as a spare is an older 6AL that has the correct mating Deutsch ends attached for quick install in the event of a failure. With the addition of the legacy cable and one parameter change in 7730 program the ignition is working properly.

The biggest problem I’ve seen multiple times with Grid installs, is that the Male Deutsch plugs with the Female pins, has pins not locked into position properly during assembly. Looking at the plate front (if there’s any assembly grease in the plate holes, blow this out with compressed air), the female pins should be tight against the back of the plate. If not, prying the flat plastic front plate off with a small screwdriver allows access to the pins that can be pulled into locking position and plate re-installed.

MSD 7720 has much power. NGK plugs with .030 gap new will have a .044+ gap after 500 runs in my engine. Still runs properly with wider gap. I have a new set of Autolites I want to try at next change.
 
Posts: 1890 | Location: 53056 | Registered: December 30, 2009Reply With QuoteReport This Post
DRR Trophy
Picture of Rodney Pryor
posted Hide Post
I recently experienced a new MSD 7720 that a no start condition. There was a weak ignition spark when using my MSD Tester. The pins in the Deutsch connector were not properly locked into position so I thought that would fix the issue. It did not. So I installed another new MSD 7720 and that fixed the issue.
 
Posts: 103 | Location: Richmond, VA | Registered: December 07, 2002Reply With QuoteReport This Post
DRR Sportsman
Picture of Mike Frizie
posted Hide Post
I had a 7al2 that went bad , and only symptom was the motor was a .10 slow out of nowhere until sent in for repair, was told it couldnt keep up keep up under a load. . Just curious if the 7720’s have done this.


Michael Frizie
ET 2471
2011 Diamond Chassis Dragster
 
Posts: 535 | Location: Winston, GA | Registered: April 10, 2002Reply With QuoteReport This Post
DRR Sportsman
Picture of Mike Frizie
posted Hide Post
Never happened?


Michael Frizie
ET 2471
2011 Diamond Chassis Dragster
 
Posts: 535 | Location: Winston, GA | Registered: April 10, 2002Reply With QuoteReport This Post
  Powered by Social Strata  
 


© DragRaceResults.com 2022