Share |
DragRaceResults.Com    Bracket Talk    Bracket Talk Forum  Hop To Forum Categories  Tech Talk - by Abruzzi    Mega 200 stumble
Go
New
Find
Notify
Tools
Reply
  
Mega 200 stumble
 Login/Join
 
DRR Sportsman
Picture of Ron Gusack
posted
I'm a delay box novice that decided to put a brake in my 400 a few years ago just so I had the option to run top. I bought a Mega 200 and my first couple hits had a slight stumble when the brake released. Launch rpm was around 2800. I was advised to go higher and I went as high as 3200 with the same results. I was advised to get the air activated cylinder carb linkage, but the results were the same. Went back to solid linkage and I made a pass without the box using the 2 step at 2900 and it left great. That makes me think the 6al2 with the internal 2 step or the brake isn't the issue. The stumble is so slight that I can't see it with my data logger. The rpm is bouncing because of the 2step and maybe it has one more bounce after the box releases the brake. I think there's a way to log when I release the button on my Racepak, but I haven't researched that. I sent the box back to Digital Delay to get checked out. They said there's a rare issue of "relay bounce" but they couldn't make my box do that. They put all new stuff in my case and sent it back. I haven't tried it since getting it back from DD but I plan to on Saturday. I've got no attack plan if it messes up Saturday, but you might. Any suggestions???
 
Posts: 399 | Location: Maryland | Registered: January 23, 2007Reply With QuoteReport This Post
DRR S/Pro
Picture of Lenny5160
posted Hide Post
If there happens to be some issue with the Transbrake output on your box, you can try setting the SFO Mode to '3' and moving your transbrake wire to the SFO terminal. It is supposed to function as a backup Transbrake terminal that way.


Tony Leonard
 
Posts: 2932 | Location: Inver Grove Heights, MN | Registered: March 18, 2004Reply With QuoteReport This Post
DRR Pro
Picture of rusty
posted Hide Post
you need more idle,squirter or tip in fuel when the butterfly opens


opinions are worth what you pay for them
1.036, 6.16@ 224

 
Posts: 1216 | Location: texas | Registered: February 17, 2006Reply With QuoteReport This Post
DRR Sportsman
Picture of Ron Gusack
posted Hide Post
quote:
Originally posted by Lenny5160:
If there happens to be some issue with the Transbrake output on your box, you can try setting the SFO Mode to '3' and moving your transbrake wire to the SFO terminal. It is supposed to function as a backup Transbrake terminal that way.

Thanks for pointing that out Lenny. I saw that SFO setting but didn't understand what a "second transbrake control" was for, LOL. I'm confused about the "second delay" setting too. I'm just trying to get it to do the basic stuff.

This message has been edited. Last edited by: Ron Gusack,
 
Posts: 399 | Location: Maryland | Registered: January 23, 2007Reply With QuoteReport This Post
DRR Sportsman
Picture of Ron Gusack
posted Hide Post
quote:
Originally posted by rusty:
you need more idle,squirter or tip in fuel when the butterfly opens


I took the SLE stuff off and it stumbled with the box and left great without it. Both passes with the throttle wide open and the 2 step controlling launch rpm. I plan to put the SLE back on if I get the box to act right because I don't like the feeling of what I might be doing to the engine with the 2 step pop and spit. I've had guys tell me that the problem is all because my 2 step is set too low.
 
Posts: 399 | Location: Maryland | Registered: January 23, 2007Reply With QuoteReport This Post
DRR Pro
posted Hide Post
The miss you are experiencing using a delay box vs not using one leaving WOT is very unusual. If this were me I’d borrow a known good delay box to try.

My other question is wiring. Where is the +12v and ground for the 6al2 landed? If 6al2 is Not wired directly to battery consider trying this.
 
Posts: 1893 | Location: 53056 | Registered: December 30, 2009Reply With QuoteReport This Post
DRR Sportsman
Picture of Ron Gusack
posted Hide Post
quote:
Originally posted by markemark:
The miss you are experiencing using a delay box vs not using one leaving WOT is very unusual. If this were me I’d borrow a known good delay box to try.

My other question is wiring. Where is the +12v and ground for the 6al2 landed? If 6al2 is Not wired directly to battery consider trying this.


Thanks Mark! Borrowing a box is in the plans. When DD told me they couldn't make it mess up, but that they replaced the internals anyway, I said maybe I should buy another box. He laughed and said that's what we're sending you.

Both + & - MSD wires go from the box to a MSD noise filter and then directly to their respective battery cable terminals. Doing a voltage drop test of the t-brake terminal connector showed me that the voltage continues to drop as long as the brake solenoid is energized. I don't know if that's normal, unless those solenoids normally draw a ton. This was a garage test with no alternator running.
 
Posts: 399 | Location: Maryland | Registered: January 23, 2007Reply With QuoteReport This Post



DRR Pro
Picture of Goob
posted Hide Post
quote:
Originally posted by Ron Gusack:
quote:
Originally posted by markemark:
The miss you are experiencing using a delay box vs not using one leaving WOT is very unusual. If this were me I’d borrow a known good delay box to try.

My other question is wiring. Where is the +12v and ground for the 6al2 landed? If 6al2 is Not wired directly to battery consider trying this.


Thanks Mark! Borrowing a box is in the plans. When DD told me they couldn't make it mess up, but that they replaced the internals anyway, I said maybe I should buy another box. He laughed and said that's what we're sending you.

Both + & - MSD wires go from the box to a MSD noise filter and then directly to their respective battery cable terminals. Doing a voltage drop test of the t-brake terminal connector showed me that the voltage continues to drop as long as the brake solenoid is energized. I don't know if that's normal, unless those solenoids normally draw a ton. This was a garage test with no alternator running.


As the solenoid heats up, it creates more resistance. Slightly increasing voltage drop would be normal.
Between .6 volt to about 1 volt drop?

Solid ground connection for the solenoid?

Magnetic distributor or crank trigger?

Is the tach wire connected?

You're using an air operated SLE?
Adjust the opening rate / time??


"Despite the high cost of living, it remains popular."
Dave Cook
N375
 
Posts: 1131 | Location: Indy | Registered: November 21, 2008Reply With QuoteReport This Post
DRR Sportsman
Picture of Ron Gusack
posted Hide Post
Dave,
Brake solenoid is grounded to the starter along with the negative battery cable, the MSD box and the Racepak.

Magnetic distributor with the famous MSD corroded wheel.

Tach wire not connected

Not using air SLE
 
Posts: 399 | Location: Maryland | Registered: January 23, 2007Reply With QuoteReport This Post
DRR Pro
Picture of Goob
posted Hide Post
quote:
Originally posted by Ron Gusack:
Dave,
Brake solenoid is grounded to the starter along with the negative battery cable, the MSD box and the Racepak.

Magnetic distributor with the famous MSD corroded wheel.

Tach wire not connected

Not using air SLE


I'd put the solenoid ground to the trans case, or somewhere other than the same post with the MSD ground. But, it doesn't explain why it only does it through the delay box. Confused


"Despite the high cost of living, it remains popular."
Dave Cook
N375
 
Posts: 1131 | Location: Indy | Registered: November 21, 2008Reply With QuoteReport This Post
DRR Pro
posted Hide Post
If you look at the voltage on the Racepak data acquisition, it’ll show what voltage drop, if any, you have with the TB solenoid energized and WOT.

Sharing the ground wire, even though large in size, from the battery to the front (door car) with the ignition box is not advised. Using individual +/ - wires not shared with any other device/s to ignition directly from the battery is best for noise isolation. I use the clean / dirty wiring bus method for electrical noise isolation.

Any electrical coils (with the exception of high amp shifter coils) that produce excessive flyback voltage on my car have diodes across them. This includes the Line Lock and Trans Brake.
 
Posts: 1893 | Location: 53056 | Registered: December 30, 2009Reply With QuoteReport This Post
DRR Sportsman
Picture of Ron Gusack
posted Hide Post
quote:
Originally posted by markemark:
If you look at the voltage on the Racepak data acquisition, it’ll show what voltage drop, if any, you have with the TB solenoid energized and WOT.

Sharing the ground wire, even though large in size, from the battery to the front (door car) with the ignition box is not advised. Using individual +/ - wires not shared with any other device/s to ignition directly from the battery is best for noise isolation. I use the clean / dirty wiring bus method for electrical noise isolation.

Any electrical coils (with the exception of high amp shifter coils) that produce excessive flyback voltage on my car have diodes across them. This includes the Line Lock and Trans Brake.


Thanks Mark, I moved the msd ground wire from the starter bolt to the battery ground. Now I have the msd wire going from the box to the noise capacitor and then 12ga wire from the capacitor to the battery post.

Reading about flyback voltage is interesting and I kinda understand it, but don't know where to install or how to size the diode.
 
Posts: 399 | Location: Maryland | Registered: January 23, 2007Reply With QuoteReport This Post
DRR Pro
posted Hide Post
You can purchase Rectifier Diodes 1000 Volt rated Electronic Silicon on the internet, very inexpensive. A Line Lock would need a 3 Amp rated diode and a Trans Brake solenoid would need a 10 amp rated. You could use the higher amperage rated diode on both saving the purchase cost if desired.

Diodes used across coils for flyback are installed with the white/ gray band to the positive coil wire and other side to negative coil lead. You want to be sure to install correctly, as if it is backwards, you will have a Dead Short that will/ could damage anything else that is attached to the same positive wire.
 
Posts: 1893 | Location: 53056 | Registered: December 30, 2009Reply With QuoteReport This Post
DRR Sportsman
Picture of Ron Gusack
posted Hide Post
quote:
Originally posted by markemark:
You can purchase Rectifier Diodes 1000 Volt rated Electronic Silicon on the internet, very inexpensive. A Line Lock would need a 3 Amp rated diode and a Trans Brake solenoid would need a 10 amp rated. You could use the higher amperage rated diode on both saving the purchase cost if desired.

Diodes used across coils for flyback are installed with the white/ gray band to the positive coil wire and other side to negative coil lead. You want to be sure to install correctly, as if it is backwards, you will have a Dead Short that will/ could damage anything else that is attached to the same positive wire.


Thanks Mark, does the diode need to be installed close to the solenoid or can it be near the switch/button?
 
Posts: 399 | Location: Maryland | Registered: January 23, 2007Reply With QuoteReport This Post



DRR Pro
posted Hide Post
quote:
Originally posted by Ron Gusack:does the diode need to be installed close to the solenoid or can it be near the switch/button?

The preferred location is at the source of the load.
 
Posts: 1893 | Location: 53056 | Registered: December 30, 2009Reply With QuoteReport This Post
  Powered by Social Strata  
 

DragRaceResults.Com    Bracket Talk    Bracket Talk Forum  Hop To Forum Categories  Tech Talk - by Abruzzi    Mega 200 stumble

© DragRaceResults.com 2022